resources
  • Caché
  • Data Platform
  • Ensemble
  • InterSystems IRIS
  • InterSystems IRIS for Health

October 17, 2019 – Advisory: InterSystems Products and Apple macOS 10.15 (Catalina)

With the recent release of macOS 10.15, Apple has tightened its control mechanism, called Gatekeeper, so that it now requires executables to be notarized.  InterSystems products are not currently supported for use on macOS 10.15 and the executables have not been notarized.  (As a reminder, InterSystems products are supported on macOS as a development platform only.)

InterSystems is working to provide compatibility with macOS 10.15 for future releases of InterSystems IRIS, InterSystems IRIS for Health, Caché, and Ensemble.  Until that time, we recommend not running InterSystems products on macOS 10.15.  Another option is running InterSystems IRIS in a container on macOS including 10.15.

If you have any questions regarding this advisory, please contact the Worldwide Response Center